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1. Affordable, easy-to-use, accurate and precise 
 

  
Multimeter view Oscilloscope view 

 

Applications include: 

• Microprocessor and microcontroller power profiling and optimization 

• Hardware power optimization 

• Sleep current optimization 

• Hardware and software troubleshooting 

• Software characterization and interrupt service routine profiling 

• USB 2.0 inrush and suspend current pre-compliance testing  

• General-purpose current, voltage, power, charge, and energy measurement 

 

The Joulescope™ JS110 is the most affordable and easy-to-use precision DC energy analyzer.  It 

measures current and voltage, then computes power and energy.  Many modern battery-powered 

devices and IoT devices have a high dynamic current range, which makes accurate measurement 

difficult.  When “sleeping” the devices consume nanoamps (nA) or microamps (µA), but when active, 

they consume milliamps (mA) or amps (A).  Joulescope combines high-speed sampling and rapid 

dynamic current range switching to provide accurate and seamless current and energy measurements, 

even for devices with rapidly varying current consumption.  The unprecedented accuracy and low-cost 

of Joulescope allows every engineer on the team to measure the energy consumed by the target device 

during development.  Joulescope provides rapid feedback on how changes affect the overall product 

battery life.   

Joulescope displays instantaneous voltage, current, power, and energy, like a multimeter.  The 

multimeter provides a quick and easy summary of the present state of your device. 

Joulescope displays waveforms of voltage and current over time, like an oscilloscope.  This oscilloscope 

view allows you to identify and to troubleshoot dynamic behavior and short events, including inrush 

current, event handlers, and tasks.   



Revision 1.3 Joulescope JS110 User’s Guide Page 3 / 47 
 www.joulescope.com 

2. Key benefits 
 

• Dynamic range: Joulescope accurately measures electrical current over nine orders of 

magnitude from amps down to nanoamps. This wide range allows accurate and precise current 

measurements for modern devices.  Sleep modes are often just nanoamps (nA) or microamps 

(µA).  Active modes are often milliamps (mA) or amps (A). 

• Low voltage drop: Most multimeters and current meters have a significant voltage drop 

(sometimes called burden voltage or insertion loss), which affects the actual voltage delivered to 

the device under test.  Joulescope has a total voltage drop of 25 mV at 1 A, which keeps your 

target device running correctly. Joulescope’s extremely fast current range switching maintains 

low voltage drop even under rapidly varying current demands. 

• Makes the invisible visible:  Joulescopes measure current and voltage 2 million times per 

second with 250 kHz bandwidth.  This high sampling rate makes the power consumption of 

interrupt service routines, inrush currents, and other short events visible. 

• Easy to use:  Joulescope reports cumulative energy consumption along with real-time current, 

voltage, and power. The multimeter view clearly shows the most recent value, while the 

oscilloscope view allows you to explore changes over time.  Much simpler and more accurate 

than anything in its class! 

• Customizable:  The Joulescope host software is open source on GitHub.  You can also swap the 

banana jack front panel with front panels that have other connector types.  The front panels are 

open source on GitHub.   

• Portable: Joulescope fits in your backpack and only needs a small part of your desk.  Take 

Joulescope wherever you want to use it! 

• Affordable:  Joulescope is affordable and priced so that every developer on the team can have 

one at their desk.  With such convenient access, Joulescope allows developers to see the impact 

of their changes on energy consumption immediately.  Developers can make informed choices 

to account for battery life during design. Eliminate power consumption surprises during final 

product testing! 
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3. Key features 
 

• -1V to 15V voltage range 

• -1A to 3A current range, continuous 

• Up to 10A current pulses (<10 ms, < 3A average per second) 

• Down to 1.5 nA resolution, equivalent to 32-bits of dynamic range 

• Synchronously measures voltage and current at 2 million samples per second, 14-bit 

• 250 kHz bandwidth 

• Rapid 1 μs switching between shunt resistors for seamless dynamic current measurement 

• Computes power, total energy, and charge 

• Operates with minimal voltage disturbance between IN and OUT ports 

• Up to ±48V common-mode voltage between USB ground and IN-, IN+, OUT+, and OUT- 

• 2 general-purpose inputs and 2 general-purpose outputs 

• Programmable on/off for power cycling the target device and measuring inrush currents 

• USB 2.0 high-speed host connectivity 

• Host software support for Microsoft® Windows®, Apple® Mac® OS X®, and Linux® 

• Host software provides real-time graphs of current, voltage, and power over time 

• Host software is open source and available on GitHub 

• Swappable front panel with open-source designs on GitHub 

• Firmware upgradable 

See Section 8 for the full specifications. 
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5. What comes in the box 
Your Joulescope JS110 purchase includes: 

• Joulescope JS110 instrument 

• Banana Jack Front Panel, already installed 

• 6’ USB 2.0 A to B cable 

• T15 Torx screwdriver 

• Quick Start Guide 

• Joulescope sticker 

You will need to provide: 

• A host computer which must be running Microsoft® Windows® 10, Window 7, Apple® Mac® 

OS/X® or Linux®.  Most computers manufactured within the last five years should work.  The 

computer requires an available USB 2.0 port, at least 500 MB of hard drive / solid state drive 

storage space, and 1 GB of available RAM.   

• Suitable cable(s) to connect Joulescope to your power source  

• Suitable cable(s) to connect Joulescope to your target device. 

You need an internet connection to download the free software. 
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6. Meet Your Joulescope 
The front side of Joulescope has the connectors that connected to your target device and its regular 

power supply.  Connect your power supply positive output to IN+, and connect OUT+ to your target 

device’s positive voltage input.  Connect the target device’s ground or negative voltage input to OUT-.  

Connect IN- to your power supply ground or negative output. 

 

The LED indicates when your Joulescope is ready to collect measurements. 

 

The backside of Joulescope has the host USB connector, status LED, and GPIO connector: 

 

Use the provided USB cable to connect the USB host computer connector to your host computer.  The 

status LED indicates when the Joulescope successfully communicates with the host computer.  For 

Windows hosts, the Status LED illuminates shortly after connecting the Joulescope to the computer.  For 

Linux and macOS hosts, the Status LED will not illuminate until the Joulescope software attempts to 

connect. 

The GPIO connector provides two general-purpose inputs and two general-purpose outputs.  See 

Section 12 for details. 
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7. Quick start 
Download the host software from http://www.joulescope.com/download.  Follow the instructions on 

the download page to install the software for your platform.  Linux, macOS, and Windows 7 may require 

additional steps.  See section 9.1 for details. 

Start the Joulescope host software. 

 

Connect the Joulescope USB port to the host computer using the provided USB cable.   

 

The host software will automatically detect the connected Joulescope and start displaying data. 

 

http://www.joulescope.com/download
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Connect the Joulescope IN port to your power source.  If using a configurable power supply, set the 

voltage and current suitable for your device under test.  The maximum voltage between IN+ and IN- 

should never exceed ±15V.  IN and OUT are electrically isolated from USB, but the voltage between any 

port and USB ground should never exceed ±48V. 

 

Connect the Joulescope “OUT” port to the power input for your device under test. 

 

Operate your device under test.  The Joulescope host software starts in the Multimeter view by default.  

Use the Multimeter view to measure the current, voltage, power, charge, and energy consumption.   

Dive into more detail with the oscilloscope view.  Select View → Oscilloscope Default to display 

waveforms of voltage, current, and power over time. 
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8. Specifications 

8.1. Absolute maximum ratings 
 Min Max Unit 

USB voltage -0.3 6 V 

Max voltage applied between IN+ to IN- -20 20 V 

Max voltage applied between OUT+ to OUT- -20 20 V 

Max voltage to USB ground (IN+, IN-, OUT+, OUT-) -48 48 V 

Input current (powered, burst) -10 10 A 

Input current (powered, sustained) -3 3 A 

Input current (unpowered) -0.5 N/A (off) A 

Storage temperature -40 80 °C 

Operating temperature 0 50 °C 

Relative humidity (non-condensing) 0 95 % 

Altitude from sea level -100 2500 m 

Max voltage applied to GPI relative to USB ground -10 10 V 

 

8.2. Mechanical 
 Typical Unit 

Weight 217 grams 

Width 81 mm 

Length (including banana jack front panel) 150 mm 

Height 33 mm 

 

8.3. Recommended operating conditions 
 Test condition Min Typical Max Unit 

Operating temperature  10  40 °C 

USB supply voltage  4.5 5.0 5.5 V 

USB supply current    500 mA 

Voltage applied to IN  -1.0  15 V 

Input current continuous -1.5  3 A 

Input current pulse < 10 milliseconds,  
< 3A average 

  10* A 

Input current pulse < 100 milliseconds 
< 3A average 

  5* A 

* Suitable for handling inrush currents when connecting capacitive loads. 

8.4. Specification conditions 
Temperature 23 °C ± 10 °C 

Humidity 20% to 80% RH, non-condensing 

Calibration interval 1 year* 

* Recommended to comply with industry-standard practices, but Joulescope is designed not to need 

recalibration. 
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8.5. Current measurement specifications 
Range Accuracy Resolution Impedance Bandwidth 

10 A* ±0.3% ±7 mA 1 mA 0.01 Ω 250 kHz 

2 A ±0.3% ±1.50 mA 175 µA 0.01 Ω 250 kHz 

180 mA ±0.3% ±150 µA 15 µA 0.11 Ω 250 kHz 

18 mA ±0.25% ±15 µA 1.5 µA 1.11 Ω 250 kHz 

1.8 mA ±0.25% ±1.5 µA 150 nA 11.1 Ω 180 kHz 

180 µA ±0.25% ±150 nA 15 nA 111 Ω 70 kHz 

18 µA ±0.25% ±30 nA 1.5 nA 1111 Ω 15 kHz 

* Joulescope is designed for 3 A sustained.  See the recommended operating conditions for maximum 

durations for higher currents. 

Test current measurement bandwidth by varying the effective load impedance.  Due to load 

capacitance, altering the source voltage is not a valid method of testing current bandwidth. 

8.6. Voltage measurement specifications 
Range Accuracy Resolution Impedance Bandwidth 

15 V ±0.1% ±11 mV 1.2 mV - 250 kHz 

5V ±0.1% ±3.5 mV 400 µV - 250 kHz 

 

8.7. General specifications 
 Test condition Min Typical Max Unit 

Sampling frequency 25 °C  2000000  sps 

Sampling frequency 25 °C -20  20 ppm 

Front panel insertions    100  

 

8.8. Parasitic effects specifications 
 Test condition Min Typical Max Unit 

Current leakage (IN+ to IN-) 25 °C, +3.3V  2  nA 

Current leakage (IN+ to IN-) 25 °C, +5V  2  nA 

Current leakage (IN+ to IN-) 25 °C, +15V  3  nA 

Shunt resistor voltage, max 0 to 2 A, static  20 21 mV 

Burden voltage (IN+ to OUT+) < 1 A, banana jacks 0 25 30 mV 

Burden voltage (OUT- to IN-) < 1 A, banana jacks 0 3 8 mV 

Shunt switching time Over-range 
< 100 ns rise time 

0 0.8 1.2 µs 

Over-range settling time  0 2 5 µs 

Under-range settling time  0 2 5 µs 

 

8.9. Software-controlled fuse specifications 
 Test condition Min Typical Max Unit 

Current leakage (IN+ to OUT+) 25 °C, 3.3V  5  nA 

Current leakage (IN+ to OUT+) 25 °C, 5V  7  nA 

Current leakage (IN+ to OUT+) 25 °C, 15V  28 5000 nA 
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8.10. General Purpose Inputs & Outputs 
 Test condition Min Typical Max Unit 

Programmable logic level voltage  1.8  VUSB - 
0.2 

V 

Input leakage per pin 25 °C   ±1 μA 

Input leakage per pin    ±2 μA 

Output voltage high -100 μA Vcco-
0.1 

  V 

Output voltage high -4 mA @ 1.65 V 1.2   V 

Output voltage high -8 mA @ 2.3 V 1.9   V 

Output voltage high -24 mA @ 3 V 2.4   V 

Output voltage high -32 mA @ 4.5 V 3.8   V 

Output voltage low 100 μA   0.1 V 

Output voltage low 4 mA @ 1.65 V   0.45 V 

Output voltage low 8 mA @ 2.3 V   0.3 V 

Output voltage low 24 mA @ 3 V   0.55 V 

Output voltage low 32 mA @ 4.5 V   0.55 V 

Output impedance 10 mA 90 100 110 Ω 

GPI sample rate   2  MSPS 

Continuous output current Per pin   ±50 mA 

Total power dissipation Over output impedance   0.25 W 

 

The Joulescope uses the TI SN74LVC2T45 for both the GPIs and GPOs.  See the SN74LVC2T45 datasheet 

for more information.  Both the GPIs and GPOs are protected with the Vishay VEMI45AA-HNH, which is 

an EMI filter with ESD protection.  The VEMI45AA is a pi filter with 100 Ohm resistance and capacitance 

between 29 pF and 60 pF. 

 

GPIO Supply 

 Min Typical Max Unit 

+5V output 4.4V VBUS – 0.1 5.5 V 

Current   100 mA 

Output impedance  1  Ω 

 

http://www.ti.com/lit/gpn/sn74lvc2t45
https://www.vishay.com/docs/81385/vemi45aa.pdf
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9. Host software 
The Joulescope host software runs on a host computer and communicates with the Joulescope 

instrument over USB 2.0 high-speed.   

The software works with Microsoft® Windows® 10, Windows® 7, Apple® Mac® OS/X®, and Linux®.  For 

Linux, only Ubuntu 18.04.1 LTS is tested.  The Joulescope software only supports 64-bit operating 

systems with 64-bit python 3.6+.   

9.1. Installation 
The Joulescope software is available to download at  

www.joulescope.com/download/ 

Click on the download link for your platform.  For a list of all releases for all platforms, see 

https://download.joulescope.com/joulescope_install/index.html 

Follow the usual process to download and install the software following the on-screen directions.  

Several operating systems may require additional steps, as noted below. 

We recommend installing the Joulescope software on the native operating system, not under a virtual 

machine, due to Joulescope’s demanding USB communication requirements. 

9.1.1. Linux 
Many Linux systems, including Ubuntu, use “udev” to manage devices and grant permissions.  You will 

need to install a udev rule that grants Joulescope hardware access to your account.  Download and 

follow the instructions in this file: 

https://raw.githubusercontent.com/jetperch/pyjoulescope/master/99-joulescope.rules 

9.1.2. Windows 7 
Windows 10 and many Windows 7 machines will run without additional steps.  However, some 

Windows 7 machines do not include Microsoft’s WinUSB, the driver used by Joulescopes.  You will need 

to install the driver manually. 

1. Download https://raw.githubusercontent.com/jetperch/pyjoulescope/develop/joulescope.inf 

2. In the Windows → Run bar, type devmgmt.msc 

3. Right-click on Joulescope, select “Update Driver Software…” 

4. Select “Browse my computer for driver software” 

5. Browse to the directory where you downloaded the joulescope.inf file 

6. The driver should install, and your Joulescope should no longer have a yellow exclamation mark 

9.1.3. macOS 
The macOS distribution is currently signed, but it is not distributed through the Apple Store.  Newer 

versions of macOS, such as Catana, indicate security warnings.  You may need to control-click the 

Joulescope application, then select “open” to bypass these security warnings.  You will need to repeat 

the control-click, “open” process several times (usually twice) until macOS finally allows the Joulescope 

software to launch.  After granting this permission once, subsequent runs will run normally. 

http://www.joulescope.com/download/
https://download.joulescope.com/joulescope_install/index.html
https://raw.githubusercontent.com/jetperch/pyjoulescope/master/99-joulescope.rules
https://raw.githubusercontent.com/jetperch/pyjoulescope/develop/joulescope.inf
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9.2. Multimeter view 
Upon launching the host software, you see the multimeter view: 

 

You can return to this view at any time using View → Multimeter. 

The multimeter view provides the present operating state at a glance.  The multimeter view displays 

several quantities: 

• Electrical current in amperes (A) 

• Electrical voltage in volts (V) 

• Power in watts (W) 

• Energy in joules (J) 

• Charge in either coulombs (C) or amp-hours (Ah). 

This display, along with all other value displays in the Joulescope software, the SI standard prefixes for 

orders of magnitude: 

Prefix Power Name 

G 109 giga- 

M 106 mega- 

k 103 kilo- 

m 10-3 milli- 

µ 10-6 micro- 

n 10-9 nano- 

p 10-12 pico- 
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The multimeter view updates every half second (0.5 seconds) by default.  The software computes and 

displays the statistics over each half-second time window.  The large numbers are the mean (also called 

average) value of that quantity over the window.  The software also displays: 

• σ: The standard deviation 

• min: The minimum value 

• max: The maximum value 

• p2p: The peak-to-peak value, which is equal to (max – min) 

Note that energy does not display these additional statistics since they are not meaningful.   

Every update represents only the data recorded over the last half-second.  If you click on the 

“Accumulate” button to activate it, then the software extends the statistics to combine each new half-

second window without discarding results from previous windows.   

9.3. Oscilloscope view 
The software includes an oscilloscope view.  Click View → Oscilloscope. 

 

The first view allows you to control the connected Joulescope.  Press  to pause or resume capturing 

live data.  Press  to start and stop recording data to a file.  This feature is only available when the 

device is capturing live data. 

Current Range allows you to select Joulescope’s active shunt resistor.  Most applications use auto, 

where Joulescope automatically selects the best range.  However, you can manually force the range.  

Select off to disconnect power to the target device. 
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Voltage Range allows you to select the voltage range.  Joulescope includes a 15V range and a more 

sensitive 5V range. 

The Control widget in the Oscilloscope view also displays the energy or current consumed.  Left-click or 

select Tools → Clear Accumulators to reset the accumulators to zero.  Right-click or use File → 

Preferences → Units → Accumulator to set the displayed field to either energy or current. 

The software displays two different waveforms by default.  The top waveform is electrical current, and 

the bottom waveform is electrical voltage.  The x-axis is time.  If you have a Joulescope connected, it will 

automatically add the most recent data to the right of the waveform and shift existing data to the left.  

The y-axis data is the value measured at the corresponding point in time.  Joulescope captures data 2 

million times per second.  When zoomed out, each x-axis pixel may represent many, many samples, 

which are that pixel’s sample window. The plot displays the statistics over each pixel.  The yellow line is 

the mean (average).  The red lines are the minimum and maximum.  Power glitches, such as interrupt 

service routines, are very interesting for energy optimization.  The minimum and maximum ensure that 

you do not miss these events, even when zoomed out.  When you eventually zoom in far enough, the 

red lines disappear because 1 pixel becomes 1 sample, and the minimum and the maximum are the 

same as the average.  You can use File → Preferences → Waveform → show_min_max to disable these 

lines or display the minimum to maximum region as a fill instead.   

The software computes statistics quantities over the full-time window shown in the present view for 

each waveform.  The software displays the statistics on the right edge of the window.  The statistical 

quantities are: 

• µ: The mean (also called average) value 

• σ: The standard deviation 

• p2p: The peak-to-peak value (max - –in) 

• min: The minimum value 

• max: The maximum value 

• ∫: The integral over the time window  

The waveform view supports Annotations to present additional information, which includes: 

• A Single Marker that display information at a single point.  Names used by other equipment for 

this feature include marker and cursor. 

• Dual Markers that display information over a time window.  Names used by other equipment 

for this feature include cursors, timing markers, window, and range selection. 

To display statistics at a single point, move the mouse to the x-axis time labels near the top.  Then right-

click (control-click on Mac OS) to bring up the context menu.  Select Annotations → Single Marker. 
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Left-click the marker to move it with the mouse.  As you move the mouse over the waveforms, the 

vertical marker follows along.  The line displays statistics about that location: 

• t: The sample time for the displayed sample or window 

• µ: The mean (also called average) value 

When the location contains more than one sample per displayed pixel, the line displays statistics over 

that single pixel’s sample window: 

• σ: The standard deviation 

• p2p: The peak-to-peak value (max - –in) 

• min: The minimum value 

• max: The maximum value 

Left-click again to keep the marker in position. 

To display statistics over a selectable range, right-click on the x-axis time labels and select Annotations 

→ Dual Markers.  Left-click a marker to move it with the mouse, then left-click again to stop moving the 

marker.  Hold the Ctrl key while left-clicking to move both markers together.  Right-click (control-click on 

Mac OS) on one of the dual markers to export data or perform analysis over the selected range. 

 

Use the scroll wheel to zoom in and zoom out.  The zoom operation keeps the point under the mouse 

cursor at the same location after the zoom operation.  However, when you reach the maximum extents 

while zooming out, that point may move.  When viewing live data, the zoom operation always keeps the 

most recent data in view at the right. 
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Press the left mouse button and drag the cursor left or right to pan in time.  Pan is not supported when 

viewing live data from a Joulescope. 

The software displays the waveform on a linear scale with automatic y-axis ranging by default.  The y-

axis context menu has additional options.  Right-click (control-click on Mac OS) on the y-axis to display 

the menu. 

 

When manual ranging is activated, hover over the y-axis and use the scroll wheel to zoom in and out.  

Left-click and drag up and down to pan the y-axis. 

Use the y-axis context menu to change the y-axis scale mode.  The y-axis displays in linear coordinates 

by default but also supports a logarithmic scale.  A logarithmic scale is handy to view wide dynamic 

ranges for current and power. 

Use the y-axis context menu to hide the signal.  Click Settings at the top left to display the settings 

menu.  Select Add → [Signal Name] to display a signal not already shown. 

9.4. Energy and Charge 
The Joulescope measures current and voltage two million times per second.  It then multiplies current 

by voltage to compute power.  Joulescope then integrates power over time to compute energy.  It also 

integrates current to compute charge.  Joulescope displays energy in both the Multimeter view and 

Oscilloscope view.  This value starts accumulating when the software starts.  Use Tools → Clear Energy 

to reset it to zero at any time. 

The energy value and charge value provide a simple measurement to observe changes, especially for 

software.  You can baseline the performance of an operation by recording the measured energy or 

charge value.  You can then make changes, repeat the test, and observe the new energy or charge value.  

The oscilloscope view enables you to investigate in further detail. 

9.5. Open-source 
The host software is open source and written in Python 3.6+.  The host software consists of two layers: 

Repo name Python package name Description 

pyjoulescope_ui joulescope_ui The Joulescope User Interface written in QT/PySide2 

pyjoulescope joulescope The Joulescope “driver” which enables scripting  

 



Revision 1.3 Joulescope JS110 User’s Guide Page 21 / 47 
 www.joulescope.com 

The joulescope package was designed so that you can script custom Joulescope actions and integrate 

Joulescope into your applications.   

See the GitHub repositories for the latest details. 

https://github.com/jetperch/pyjoulescope_ui 

https://github.com/jetperch/pyjoulescope 

You can find examples for how to use Joulescope in your Python application at: 

https://github.com/jetperch/pyjoulescope_examples 

Also see the documentation: 

https://joulescope.readthedocs.io/ 

The Joulescope software depends upon other software and libraries.  See CREDITS.html for 

pyjoulescope_ui and pyjoulescope. 

https://github.com/jetperch/pyjoulescope_ui
https://github.com/jetperch/pyjoulescope
https://github.com/jetperch/pyjoulescope_examples
https://joulescope.readthedocs.io/
http://htmlpreview.github.io/?https://github.com/jetperch/pyjoulescope_ui/blob/master/CREDITS.html
http://htmlpreview.github.io/?https://github.com/jetperch/pyjoulescope/blob/master/CREDITS.html
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10. Theory of operation 
Joulescope simultaneously measures current and voltage, and then computes power and energy.  

Joulescope combines a voltmeter and a fast auto-range current shunt ammeter.   

 

10.1. Ammeter 
The shunt ammeter consists of seven (7) current ranges with six (6) different shunt resistor values 

ranging from 0.01 Ω to 1111 Ω.  Joulescope actively selects the best shunt resistor to keep the maximum 

voltage across the shunt resistor to 20 mV.  This low voltage drop minimizes the impact on the device 

under test.  Other equipment, including standard multimeters, have a much larger burden voltage that 

can cause the target device to behave unusually. 

The Joulescope amplifies the voltage across the shunt resistor and then uses an analog-to-digital 

converter (ADC) to digitize the value.  The ADC digitizes the value 2 million times per second to create 2 

million samples per second (SPS).  The Joulescope instrument sends these ADC values to the host 

software over USB.  Given a known resistor value and the measured voltage, the Joulescope uses Ohm’s 

Law to compute current.  Each Joulescope contains a calibration.  The software applies the calibration to 

convert the ADCs into measured current values.  Joulescopes are individually calibrated and tested in 

the factory to ensure that every Joulescope performs to specification. 

As the current changes, the ammeter selects the optimal shunt resistor value.  Joulescope uses 

dedicated hardware to quickly select the appropriate shunt resistor to avoid impacting the device under 

test.  The shunt value selection uses the ADC output, dedicated over-range analog hardware, and a 

unique algorithm that runs in an FPGA.  The FPGA selects the active shunt resistors using MOSFETs, 

which were carefully qualified to meet Joulescope’s demanding performance characteristics. 
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The shunt resistor selection does take some time.  How fast does the shunt resistor need to change to 

have a minimal impact?  The linearized equation is: 

t = C * ΔV / ΔI   

Let’s take a typical example. The target device takes 3.3V and can tolerate a temporary 3% (0.03) 

voltage glitch on a 1 amp change.  If the target device has 10 μF of capacitance, the required shunt 

resistor switching time is approximately: 

10 μF * 3.3 V * 0.03 / 1 A = 1 μs   

Joulescope was designed to achieve 1 µs switching speed to meet this demanding case.  Most target 

systems have larger capacitance and less dramatic step current changes.  In all cases, the shunt resistor 

selection is always make-before-break to ensure uninterrupted connectivity to the target device.   

10.2. Voltmeter 
The voltmeter measures the voltage between IN+ and IN-.  The voltmeter scales the input voltage, and 

uses an analog-to-digital converter (ADC) to digitize the value.  The Joulescope instrument sends the 

voltage samples, along with the current samples, to the host computer.  The software applies the 

calibration to convert from ADC values to actual voltage. 

The voltmeter has two different ranges, and you can manually select the best range for your application.  

The 5V range provides higher resolution for smaller voltages, while the 15V range allows for larger 

voltage measurements. 

10.3. Host Computer 
The Joulescope instrument requires a host computer to operate.  The Joulescope instrument sends 2 

million current and voltage samples per second immediately to the host computer over USB.  Unlike 

traditional oscilloscopes, a Joulescope is always capturing data.  The terms “trigger” and “sample buffer” 

do not fully apply to the Joulescope device, since all sample data arrives at the host computer.  The 

Joulescope User Interface (UI) temporarily stores capture data in a circular buffer.  The UI allows you to 

adjust the buffer size to use your host computer’s RAM.  Joulescope can also record to a file, and the 

capture size is only limited by your computer’s available storage on your hard disk drive or solid-state 

drive. 

The Joulescope host software is open-source.  The pyjoulescope “driver” communicates with the 

appropriate operating system USB driver.  Joulescopes use Microsoft’s WinUSB on Windows, which is 

included by default with the Windows operating system.  On Linux and macOS, Joulescope uses the 

popular, open-source libusb driver.  The pyjoulescope driver provides an easy-to-use scripting 

environment.  You can also use the driver to build integrated applications, such as the Joulescope UI, 

that use the Joulescope instrument data. 

10.4. Power, Energy, Charge, and Statistics 
Joulescopes only measure current and voltage.  The Joulescope software uses math to compute the 

power, energy, and charge.  Power is the current multiplied by the voltage: 

P   =   V * I   =   V2 / R   =   I2 * R 
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Energy is the integral of power over time.   

E  = ∫𝑃 𝑑𝑡 

When we talk about energy, we often mean the energy consumed over a specific time interval, which is 

the definite integral: 

E  =  ∫ 𝑃 𝑑𝑡
𝑇

𝑡=0

   ≈     ∑𝑃𝑛 𝛥𝑡

𝑁

𝑛=0

 

The Joulescope host software performs the discrete-time Euler integration shown to the right.  The 

Joulescope software carefully manages the numerical precision to ensure that it computes energy 

correctly.  IEEE double-precision floating-point numbers do not provide sufficient precision. 

Charge is the integral of current over time.   

C  =  ∫ 𝐼 𝑑𝑡
𝑇

𝑡=0

   ≈     ∑𝐼𝑛 𝛥𝑡

𝑁

𝑛=0

 

Charge and energy are mathematically similar.  Both voltage and current contribute to energy, but only 

current contributes to charge. 

10.5. High impedance / low leakage 
Joulescope measures currents at nanoamp resolutions and accuracies.  Many contemporary devices 

have input impedances of 1 MΩ to 10 MΩ, which is not good enough.  At 3.3V, a 10 MΩ load draws: 

3.3V / 10 MΩ  = 330 nA 

Joulescope features a combined input impedance and leakage current of approximately 1 GΩ.  This high 

input impedance allows Joulescope to make accurate and precise low current measurements. 

10.6. Electrical isolation 
The sensor side of Joulescope is electrically isolated from the host computer.  This isolation allows you 

to insert Joulescope into your test system without worrying about ground issues, including ground loops 

and ground noise.   
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11. How to swap the front panel 
Joulescope comes standard with a banana jack front panel.  However, Joulescope is designed to be 

flexible and can support other connector types. 

 

The front panel design is open source, and available on GitHub: 

https://github.com/jetperch/joulescope_front_panels 

To swap the front panel, you will need: 

• T15 Torx screwdriver 

• The new front panel 

Swapping the panel is easy, but you do need to take proper precautions to avoid damaging your 

Joulescope.  Joulescope can be damaged by static electricity that you don’t even notice.  When you 

expose the Joulescope main board, be sure only to handle it by the board edges.  Follow these steps 

carefully: 

• Completely disconnect the Joulescope, including IN, OUT, and USB ports. 

• Use the Torx screwdriver to remove the four screws at the corners of the existing front panel. 

• Gently push the Joulescope’s USB connector into the Joulescope body.  This action will push the 

front panel out.  Expose about ½” or 1 cm.   

• Grab the sides of the main board in one hand, being careful not to touch any other part of the 

board.   

• Grab the existing front panel by the sides and carefully pull it directly out. 

• Grab the new front panel by the sides, align the pins, and carefully push it in. 

• Fully seat the front panel in the black plastic bezel.  You may need to gently guide the board to 

ensure that the USB connector fits in the back panel. 

• Use the Torx screwdriver to install the four screws at the corners of the existing front panel. 

 

https://github.com/jetperch/joulescope_front_panels
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12. GPI & GPO 
The Joulescope contains two (2) general-purpose inputs (GPI) and two (2) general-purpose outputs 

(GPO), located near the host USB connecter.   

 

These signals enable time-synchronization with the device under test and other external equipment.  

The user interface can display GPIs time-synchronized with current, voltage, and power in the 

oscilloscope view.   

One intended application for the GPIs is to allow the target microcontroller firmware to identify areas of 

interest.  The microcontroller can toggle bits so that you can easily see the energy consumption in the 

marked time windows.   

When the GPI feature is activated, the voltage and current samples will only be 13 bits (the GPI will be in 

the LSB), not the full 14-bits. 

Both GPI and GPO are referenced to USB ground.  Many applications using Joulescope will want isolated 

GPI/GPO for improved performance.  When selecting an isolation solution, consider: 

• Electrical isolation 

• Self-powered target interface with very low power from target device – leakage currents only 

• Variable voltage technology levels with an external reference voltage 

• ESD protection 

• Overvoltage protection (GPO) 

• Short circuit protection (GPO) 

• Very high (GΩ) input impedance (GPI) 

To control the GPIO, add the GPIO Widget by selecting View → GPIO. 

 

Select the reference voltage for your GPIO, which is configurable from 1.8V to 5.0V.  This voltage 

determines the OUT0 and OUT1 output voltages.  The input threshold voltage is one half of this voltage.   

Inputs are optional.  Check IN0 to enable the GPI0 input. Check IN1 to enable the GPI1 input.  To display 

either IN0 or IN1, select Settings → Add, then select either in0 or in1. 
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Manually toggle OUT0 by pressing the OUT0 button.  Manually toggle OUT1 by pressing the OUT1 

button.   
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13. Electrical Isolation 
The Joulescope is electrically isolated between the USB interface and the IN/OUT sensor.  Joulescope is 

rated to ±48V between USB ground and any of IN+, IN-, OUT+, and OUT-.  The individual component 

ratings far exceed this specification.  The components are: 

Part # Mfgr Description Isolation 
working 

Isolation 
60s 

Isolation 
1 s 

760390014 Wurth Transformer 400 VRMS 2500 VAC 3125 VAC 

Si8661BB-B-IS1 Silicon Labs Digital isolator 445 VRMS  4500 VRMS 

TLP2361(TPL,E Toshiba Opto isolator 500 VRMS 3750 VRMS  

 

The printed circuit board (PCB) clearance between the isolated sensor side and the USB host side is 

1 mm.  The use of an aluminum enclosure effectively limits the isolation voltage and requires that USB 

chassis ground surrounds the sensor edges.  If you use Joulescope in a custom application without the 

standard enclosure, the four chassis ground rails (2 top & 2 bottom) can be cut around the isolation line 

to give a 4 mm PCB clearance between the USB host side and the sensor side. 
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14. Typical Behavior 
This section contains information regarding typical Joulescope behavior. 

14.1. Step Response 
Joulescope is a shunt ammeter with incredibly fast autoranging.  This section contains typical 

autoranging measurements. 

The test setup includes a Joulescope, a custom load board, a power supply, a computer, and some 

cables.  A custom load board is the Joulescope target.  The load board was specifically designed for the 

sole purpose of creating very fast, repeatable edges.  It has a 1 MΩ resistor in parallel with a 1Ω resistor.  

The board contains a momentary pushbutton and debouncer, which is the input to the MCP1416 

MOSFET driver.  The MCP1416 drives the FDMC7678 MOSFET, which enables or disables the 1Ω resistor.  

The entire circuit is powered by a 9V battery and connected to the Joulescope OUT. 

The power supply is a Siglent SPD3303X-E bench supply configured for 1.00V and 2.9A.  The supply is 

connected to Joulescope IN.  Any bench supply with reasonable transient performance should do. 

 

Figure 1: The step response test setup 

The normal Joulescope user interface software captures data while pressing the target board’s switch to 

toggle the MOSFET & 1Ω resistor.  A custom Python script reads the data, processes the data, and 

creates plots.  The python script finds each edge and aligns them so that they can be plotted together.  

The plots show rising edges in the left column and falling edges in the right column.   

The first capture “step_2A.png” is the baseline with Joulescope auto-ranging disabled and set to a fixed 

2A range.  The rise time you see is due to the Joulescope bandwidth.  The actual edge is much, much 

faster.   
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Figure 2: Step response with fixed 2A range 

The second capture “step_autorange.png” is with auto-ranging.  The two samples after over-range tend 

to contain “garbage” data that messes up the y-axis range, so they are omitted.  These samples are 

captured at 2 MSPS (500 ns).  Joulescope’s stated bandwidth is 250 kHz (4 µs = 8 samples).   

 

Figure 3: Step response with autoranging 
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The Joulescope specification states that range switching occurs within 1.2 µs max.  This specification 

determines how much (or in the case of Joulescope, how little) voltage drop happens when the target 

changes current demands.  The Joulescope specification gives over-range settling time is 2 µs typical 

with 5 µs max.  This specification determines how well Joulescope can measure data through the 

transition.  Any auto-ranging ammeter needs to be VERY fast to limit voltage variations at the target 

device, and Joulescope was designed to meet these demanding requirements. 
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15. Compliance 
For additional compliance information, see 

https://www.joulescope.com/compliance/JS110 

 

15.1. United States 

15.1.1. FCC Notice 
This equipment has been tested and found to comply with the limits for a Class A digital device, 

pursuant to part 15 of the FCC Rules. These limits are designed to provide reasonable protection against 

harmful interference when the equipment is operated in a commercial environment. This equipment 

generates, uses, and can radiate radio frequency energy and, if not installed and used in accordance 

with the instruction manual, may cause harmful interference to radio communications. Operation of this 

equipment in a residential area is likely to cause harmful interference in which case the user will be 

required to correct the interference at his own expense. 

Operation of this equipment in a residential area is likely to cause harmful interference in which case the 

user will be required to correct the interference at his own expense. 

Changes or modifications not expressly approved by the party responsible for compliance could void the 

user’s authority to operate the equipment. 

This device complies with part 15 of the FCC Rules. Operation is subject to the following two conditions: 

(1) This device may not cause harmful interference, and (2) this device must accept any interference 

received, including interference that may cause undesired operation. 

15.2. Europe 
Warning – This is a Class A product. In a domestic environment this product may cause radio 

interference, in which case the user may be required to take adequate measures. 

 

In accordance with the European Waste Electrical and Electronic Equipment Directive 
(WEEE), this device needs to be recycled in accordance with local regulations.  

 

15.3. Safety 
Joulescope is an Extra-Low Voltage device as per IEC 60038.  Joulescope is intended for INDOOR USE 

only. 

15.4. RoHS Directive 2011/65/EU, 2015/863/EU 
This product is CE marked and complies with the European Union’s Directive 2011/65/EU OF THE 

EUROPEAN PARLIAMENT AND OF THE COUNCIL of 8 June 2011 on the restriction of the use of certain 

hazardous substances in electrical and electronic equipment. 

EU Directive 2015/863 of 31 March 2015 amends Annex II to Directive 2011/65/EU of the European 

Parliament and of the Council as regards the list of restricted substances. 

https://www.joulescope.com/compliance/JS110
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15.5. Country of origin 
United States of America 

Made in Maryland, USA. 
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16. Maintenance 
Joulescope is designed for minimal maintenance.  To clean your Joulescope, disconnect all wires from 

the unit.  You can gently wipe the unit with a damp cloth using water only.  Using rubbing alcohol or 

other cleaning agents may damage your Joulescope.  Do not submerge.   

Joulescope is factory calibrated and should continue to function within specifications over its operating 

life.  For critical or demanding applications, you may choose to follow industry-standard practices and 

have your Joulescope recalibrated annually.  Tra-Cal, located in Maryland, USA, provides authorized ISO 

17025:2017 calibration and recalibration.  You can submit your request at: 

https://nscainc.com/calibration-repair-rfq-form/ 

Recalibrating Joulescope requires custom equipment and trained personnel.  Only Jetperch LLC and 

Tra-Cal are authorized to perform recalibration.   

16.1. Verification Procedure 
Calibration should normally find that the Joulescope instrument still operates within specification.  

Although calibration can only be performed by authorized vendors, any facility capable of performing 

precision multimeter calibration can verify that a Joulescope is operating within specification.  This 

section describes the verification procedure. 

16.1.1. Preliminary operations 
1. Download the host computer software from https://www.joulescope.com/pages/downloads 

2. Install the software 

3. Download the validation spreadsheet from 

https://download.joulescope.com/docs/validation/index.html 

4. Connect your Joulescope to the host computer using the provided USB cable.   

5. Select View.  If the first Multimeter is not already selected, select it. 

6. Select View.  If Control is not already selected, select it. 

7. Open the validation worksheet in Excel and fill in the Device Under Test Information. 

8. Select File → Save As for this device calibration. 

9. Optionally configure your Test Uncertainty Ratio (TUR) to your desired level.  We recommend 

following industry-standard practices and set TUR to 4 or greater. 

16.1.2. Voltage Validation Process 
1. Connect calibrator OUT terminals to the Joulescope IN terminals, observing polarity. 

2. Connect a load to the Joulescope OUT terminals if recommended by your calibrator.  Otherwise, 

leave the OUT terminals unconnected. 

3. In the Joulescope UI, select Voltage Range to 15V. 

4. Configure the calibrator to the target voltage. 

5. Record the actual calibrator voltage, the calibrator’s uncertainty at that voltage, and the 

Joulescope’s measured voltage as displayed by the Joulescope UI. 

6. Repeat 4 and 5 for each target voltage. 

7. Repeat 2 through 6 for the 5V range. 

The following image shows the calibration spreadsheet: 

https://nscainc.com/calibration-repair-rfq-form/
https://www.joulescope.com/pages/downloads
https://download.joulescope.com/docs/validation/index.html
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During the test process, you should fill in all light-blue cells with measurement data.  All TUR values 

should be green.  Yellow indicates that the test setup lacks sufficient accuracy.  All “As Measured” values 

should be green.  Red indicates that the Joulescope does not meet specifications. 

16.1.3. Current Validation Process 
The current calibration process can be performed using several methods.  In all cases, the goal is to 

generate a current close to the target current.  Strict accuracy on the generated current is not required.  

However, a reference measurement is required.   

The general process is 

1. Select the Current Range in the Joulescope UI 

2. Configure the target current. 

3. Record the applied current as measured by the reference, reference’s uncertainty at that 

current, and the Joulescope’s measured current as displayed by the Joulescope UI. 

4. Repeat 2 and 3 for each target current 

5. Repeat 1 through 4 for each current range. 

15V Range

Target Units Applied

Applied 

Uncertainty

Expected 

Accuracy

Test 

Uncertainty 

Ratio Lower Limit

As 

Measured Upper Limit

0.000 V 0.011 0.0 -0.011 0.011

3.000 V 0.011 0.0 -0.011 0.011

6.000 V 0.011 0.0 -0.011 0.011

9.000 V 0.011 0.0 -0.011 0.011

12.000 V 0.011 0.0 -0.011 0.011

15.000 V 0.011 0.0 -0.011 0.011

5V Range

Target Units Applied

Applied 

Uncertainty

Expected 

Accuracy

Test 

Uncertainty 

Ratio Lower Limit

As 

Measured Upper Limit

0.000 V 0.004 0.0 -0.004 0.004

1.000 V 0.004 0.0 -0.004 0.004

2.000 V 0.004 0.0 -0.004 0.004

3.000 V 0.004 0.0 -0.004 0.004

4.000 V 0.004 0.0 -0.004 0.004

5.000 V 0.004 0.0 -0.004 0.004

Voltage Measurement
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Note that many of the test cases are for a 0.0 amp target current.  In this setup, you can simplify the 

setup and leave the Joulescope instrument disconnected, or optionally short the Joulescope OUT 

terminals with a banana jumper wire. 

Numerous valid test equipment methods exist to generate and accurately measure the target current.  

You may select a method that is appropriate for your equipment.  The Joulescope has a very large 

current range, and you will need to accurately measure from 18 µA to 3 A.  You may need to employ 

more than one method to cover the entire current range with a sufficient TUR.  Possible methods 

include:  

Method 1: Reference current source 

If you have a reference current source, connect the current source to the Joulescope IN terminals, 

observing polarity.  Connect the Joulescope OUT+ and OUT- terminals using a banana jack cable.   

10 A Range

Target Units Applied

Applied 

Uncertainty

Expected 

Accuracy

Test 

Uncertainty 

Ratio Lower Limit

As 

Measured Upper Limit

0.000 A 0.007 0.0 -0.007 0.007

0.500 A 0.007 0.0 -0.007 0.007

1.000 A 0.007 0.0 -0.007 0.007

2.000 A 0.007 0.0 -0.007 0.007

3.000 A 0.007 0.0 -0.007 0.007

2 A Range

Target Units Applied

Applied 

Uncertainty

Expected 

Accuracy

Test 

Uncertainty 

Ratio Lower Limit

As 

Measured Upper Limit

0.0000 A 0.0015 0.0 -0.0015 0.0015

0.5000 A 0.0015 0.0 -0.0015 0.0015

1.0000 A 0.0015 0.0 -0.0015 0.0015

1.5000 A 0.0015 0.0 -0.0015 0.0015

2.0000 A 0.0015 0.0 -0.0015 0.0015

180 mA Range

Target Units Applied

Applied 

Uncertainty

Expected 

Accuracy

Test 

Uncertainty 

Ratio Lower Limit

As 

Measured Upper Limit

0.00 mA 0.15 0.0 -0.15 0.15

180.00 mA 0.15 0.0 -0.15 0.15

18 mA Range

Target Units Applied

Applied 

Uncertainty

Expected 

Accuracy

Test 

Uncertainty 

Ratio Lower Limit

As 

Measured Upper Limit

0.000 mA 0.015 0.0 -0.015 0.015

18.000 mA 0.015 0.0 -0.015 0.015

1.8 mA Range

Target Units Applied

Applied 

Uncertainty

Expected 

Accuracy

Test 

Uncertainty 

Ratio Lower Limit

As 

Measured Upper Limit

0.0000 mA 0.0015 0.0 -0.0015 0.0015

1.8000 mA 0.0015 0.0 -0.0015 0.0015

180 µA Range

Target Units Applied

Applied 

Uncertainty

Expected 

Accuracy

Test 

Uncertainty 

Ratio Lower Limit

As 

Measured Upper Limit

0.00 µA 0.15 0.0 -0.15 0.15

180.00 µA 0.15 0.0 -0.15 0.15

18 µA Range

Target Units Applied

Applied 

Uncertainty

Expected 

Accuracy

Test 

Uncertainty 

Ratio Lower Limit

As 

Measured Upper Limit

0.000 µA 0.030 0.0 -0.030 0.030

18.000 µA 0.030 0.0 -0.030 0.030

Current Measurement
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In step (2), directly configure the reference current source to generate the target current. 

In step (3), read the applied current from the reference current source. 

Method 2: Reference ammeter with current source 

Connect an inaccurate current source to the Joulescope IN terminals, observing polarity.  Connect the 

Joulescope OUT- terminal to the – terminal of the reference ammeter.  Connect the Joulescope OUT+ 

terminal to the reference ammeter + terminal.   

In step (2), configure the inaccurate current source to the target current. 

In step (3), read the applied current from the reference ammeter. 

Method 3: Reference ammeter with voltage source and variable load resistor 

Connect an inaccurate voltage source to the Joulescope IN terminals, observing polarity.  Connect the 

Joulescope OUT+ terminal to one terminal of a variable load resistor.  Connect the other variable load 

resistor terminal to the reference ammeter + terminal.  Connect the reference ammeter – terminal to 

the Joulescope OUT- terminal.   

In step (2), select a target voltage and resistance combination to give the target current as computed 

using Ohm’s law: I = V / R.  Configure the load resistance, configure the voltage source, then enable the 

voltage output.  Ensure that the voltage stays between 0 and 15V.  We recommend adding a step 3.5 to 

disable the voltage output before changing the load resistance for the next target current. 

In step (3), read the applied current from the reference ammeter. 
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17. Troubleshooting 
This section contains common troubleshooting tips. 

17.1. The Joulescope UI is not working as expected 
If you are using Joulescope UI 1.0 or newer and the UI is still running, select Help → Report Issue.  Fill in 

your name and email so that we can reply to you, then enter a description.  Click Submit. 

In many cases, you can resolve the issue by clearing the Joulescope UI configuration to revert to default 

settings.  Select File → Clear config and exit, and then restart the Joulescope UI. 

If the Joulescope UI 1.0 or newer does not start correctly, you should see an error window: 

 

Fill in your name and email so that we can reply to you, then enter a description.  Click Submit.   

Select either Revert to previous configuration or Revert to defaults for the recovery option on the next 

page. 
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17.2. JS110 is not recognized by the host computer 
Ensure that the instrument is connected by USB to the host computer.  Ensure that the USB connection 

is directly to a USB port on the host computer.  Avoid any USB hubs, docks, or adapters.  For desktop 

PCs, use a motherboard port on the back as some front USB ports use a USB hub internally. 

For Linux machines, ensure that you have appropriate permissions.  You will usually need to add the 

udev rules. 

17.3. Offset error 
The JS110 is designed to never need recalibration, but it can become damaged.  The most common 

indicator of damage is an offset error in one or more current ranges.  

To diagnose this issue, disconnect all cables from the sensor-side IN and OUT.  Using the Joulescope UI, 

manually select each current range and note the offset.  Using the Joulescope UI 1.0, select View → 

Multimeter, then select Widgets → Device Control.  Rearrange the widgets.  Manually select each 

Current range in turn, and note the measure current offset at the top left of the Multimeter widget. 

 

The current ranges should be within the offset accuracy specifications shown in Section 8.5.  If you find 

that a current range or two is out of specification, the most likely cause is damage to one of the shunt 

resistor selection MOSFETs.  Known ways to damage these MOSFETs include overvoltage, excessive 

electrostatic discharge, overcurrent, and reverse current while the JS110 is unpowered. 

You can attempt repair of the MOSFET corresponding to the damaged range: 

https://raw.githubusercontent.com/jetperch/pyjoulescope/master/99-joulescope.rules
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Current Range Reference Designator Part Number 

18 µA Q1 ZXMP10A13FTA 

180 µA Q2 ZXMP10A13FTA 

1.8 mA Q3 IRLML2244TRPbF 

18 mA Q4 IRLML2244TRPbF 

180 mA Q5 SI7615ADN-T1-GE3 

2A Q6 SI7615ADN-T1-GE3 

10A Q6 SI7615ADN-T1-GE3 
 

After repair, ensure that you remove all solder flux, thoroughly dry the printed circuit board, and allow 

the printed circuit board to return to room temperature. 

17.4. Unable to measure the full voltage range 
You apply a known voltage across IN+ and IN-, but the JS110 measures a smaller voltage.  First ensure 

that you have the Voltage range set to 15 V.  If you are using the Joulescope UI 1.0, you can find this 

setting in the Device Control widget. 

If the JS110 is set to the 15 V current range, then the JS110’s Ćuk converter may not be generating a 

sufficient voltage.  The most likely cause is that one of the capacitors failed.  Open the JS110 and 

measure the voltage across C116 or C120, which are the two capacitors in the Ćuk converter that seem 

to fail more than they should.  You should see -16V. 

When the JS110 is powered off, you can use a multimeter to measure their resistance across these 

capacitors.  You should measure 10 kΩ or more in circuit.  Note that you may need to wait for the 

multimeter to charge up the capacitors to make this measurement. 

If the voltage is not close to -16 V, or the resistance measured too low, then you can attempt repair by 

replacing them.  They are 4.7 uF 1206 (imperial) 50V 20% X5R.  One suitable part is UMK316BJ475KL-T. 

17.5. Unable to open in Joulescope UI 
In Windows, the device appears in Device Manager.  However, when opening the Joulescope UI, the 

device does not connect.  In the Device Control widget, the “Open and close device” circle is not 

available and grayed out. 

The most likely cause is a fault on the sensor-side of the JS110.  When the UI attempts to open the 

device, it powers on the sensor-side.  If the sensor-side consumes too much power due to a hardware 

failure, then the host software will time out while trying to initialize the JS110’s sensor-side. 

The normal failure is that U33 becomes hot.  U33 is a TI TPS2552 current limiter which drops the voltage 

and dissipates power on overcurrent conditions. 

The most common failure that causes overcurrent are the Ćuk converter capacitors C116 and C120.  See 

17.4 for troubleshooting and repair. 
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17.6. Inaccurate measurements in the presence of strong RF 
The JS110 is susceptible to strong RF.  The JS110 is a shunt ammeter that maintains a maximum of 20 

mV across the shunt resistor.  Nearby transmitters can easily induce much larger voltages.  For example, 

30 dBm = 1 W = 20 V peak-to-peak in a 50 Ohm transmission line.  Even 20 dBm = 0.1 W = 6.324 V peak-

to-peak.  While the JS110 does have some input filtering, the filtering is very limited and the front-end 

opamp has no internal EMI attenuation. 

The JS110 is also an unbalanced instrument, meaning that its measurement range is biased towards 

positive measurements.  For the same current range, the positive measurement limit is about five times 

the negative limit.  High frequency signals will saturate the JS110’s range, which clips at the 

measurement extremes rectifying the RF signal.  When this situation occurs, the JS110 will always 

measure higher current than actual. 

The JS110 is often used with target devices that are RF transmitters.  To minimize RF pickup, we 

recommend the following: 

• Twist together the wires going to IN+ and OUT+ to minimize the loop area.  This minimizes 

coupling from the antenna to the JS110 current sense wires. 

• Keep the JS110 at least 1 wavelength away from the antenna to minimize near-field coupling 

directly to the JS110 enclosure. 

• Keep the host-side USB connection away from the antenna, too.   

• For more accurate current measurement, connect IN+ and OUT+ as a twisted pair directly from 

your target device.  Consider placing a ferrite bead at each end of the twisted wire. 

• Consider upgrading to the Joulescope JS220 which is a balanced instrument (equal + and - limits) 

and has further filtering improvements to minimize RF interference. 
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18. Warranty 
The Joulescope JS110 is warranted to be free from defects in materials and workmanship for a period of 

one year from the date of purchase.  If your Joulescope becomes inoperative from such a defect within 

the warranty period, Jetperch will either repair or replace your unit, at Jetperch’s discretion. 

This warranty covers normal use.  The warranty does not cover damage which occurs during shipment.  

The warranty does not cover damage from improper use, misuse, abuse, tampering, alteration, accident, 

software hacking, or recalibration other than by an authorized recalibration provider. 

Jetperch LLC makes no other representations or warranties, express or implied, of any kind including, 

but not limited to, any implied warranty of merchantability or fitness for a particular purpose.  Jetperch 

shall not be liable for loss of use of Joulescope.  Jetperch will not be liable for any other incidental or 

consequential damages, expenses, or financial losses, nor will Jetperch be liable for claims of such 

damages.   

To submit a warranty claim, contact support@jetperch.com.  You will need to provide your name, 

address, phone number, and email.  You will also need to provide proof of purchase, such as a purchase 

receipt, that contains the original date of sale. 

mailto:support@jetperch.com
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19. Contact 
To purchase this product, visit: 

https://www.joulescope.com 

To submit a warranty claim, first review the warranty section above.  You can submit warranty claims to: 

support@jetperch.com 

If you have questions regarding operation of Joulescope, search the website at: 

https://www.joulescope.com/  

And visit the forum: 

https://forum.joulescope.com/ 

For compliance information, see 

https://www.joulescope.com/compliance/JS110 

If you wish to contact Jetperch regarding the operation of your Joulescope, contact us through email at: 

support@jetperch.com  

 

 

Location 

Jetperch LLC 

3470 Olney - Laytonsville Rd. 

Suite 104 

Olney, MD 20832-1734 

USA 

 

https://www.joulescope.com/
mailto:support@jetperch.com
https://www.joulescope.com/
https://forum.joulescope.com/
https://www.joulescope.com/compliance/JS110
mailto:support@jetperch.com
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20. Glossary 
 

Accuracy 

The average variation in the bias between measurements and truth.  Good measurements are both 

accurate and precise. 

Ammeter 

A device that measures electrical current. 

Burden Voltage 

The voltage drop that occurs through the test equipment device.  For shunt ammeters, the burden 

voltage includes the voltage across the shunt resistor, connectors, fuses, and any additional resistance in 

the device. 

Current 

The flow of electric charge per time from positive voltage to negative voltage, measured in amperes (A), 

often called amps.  One amp is one coloumb of charge flowing per second.  One coloumb is 

approximately 6.242 x 1018 electrons, but electric current is defined opposite to the electron flow. 

Energy 

The total power exerted over time, measured in joules (J).  Energy is the time integral of power. 

Insertion Loss 

The loss in signal power due to a device in the signal path, most commonly used in reference to radio 

frequency (RF) or telecommunications.  See Burden Voltage. 

Multimeter 

A multifunction device that usually incorporates a voltmeter and shunt ammeter, at a minimum.  A 

standard multimeter supports only one measurement quantity at a time. 

Ohm’s Law 

The equation that relates voltage, current and resistance: V = I * R 

Oscilloscope 

A device that graphically displays a one or more signals, usually voltages, varying over time as a two-

dimensional plot with time on the x-axis and the signal on the y-axis. 

Power 

The time-rate of doing work, measured in watts (W).  Power is voltage multiplied by current. 

Precision 

The amount of variation between measurements of the same value relative to each other.  Good 

measurements are both accurate and precise. 

Resistance 

The quantity of opposition to the flow of electric current. 

Shunt Ammeter 

An ammeter that measures the voltage across a resistor, and then uses Ohm’s Law to compute current. 
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Shunt Resistor 

The resistor used by “Shunt Ammeters” to detect current using Ohm’s Law:  I = V / R.  Given a known R 

and a measured V, the ammeter computes I. 

Universal Serial Bus (USB) 

The now ubiquitous standard for connecting computers and peripherals.  Joulescope connects to the 

host computer using USB 2.0 high-speed. 

Voltage 

The electric potential difference, measured in volts (V). 

Voltmeter 

A device that measures electrical voltage. 
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21. User’s guide information 
This section contains information regarding this document.  See the other sections of this document for 

information regarding the Joulescope product. 

21.1. Copyright notice 
© 2019-2020 Jetperch LLC 

All material in this User’s Guide, including the text, images, design, and logos, are owned by Jetperch 

LLC, either through copyright or trademark, unless otherwise indicated.  No part of this User’s Guide 

may be reproduced in any form or by any means without prior written consent from Jetperch LLC as 

governed by the United States and international copyright laws.   

21.2. Publisher 
Jetperch LLC 
3470 Olney – Laytonsville Rd 
Suite 104 
Olney, MD  20832-1734 
USA 

21.3. Warranty 
The Joulescope JS110 User’s Guide is provided AS-IS with no other representations or warranties, 

expressed or implied, of any kind including, but not limited to, any implied warranty of merchantability 

of fitness for a particular purpose.  Jetperch LLC does make reasonable efforts to present accurate and 

reliable information in this Joulescope JS110 User’s Guide. 

The information in this User’s Guide is subject to change.  The most up-to-date version of this User’s 

Guide can be retrieved from http://www.joulescope.com/.    

http://www.joulescope.com/
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21.4. Change log 
Revision Date Description 

1.3 2023 Oct 3 Improved troubleshooting section 

1.2 2023 Sep 15 Added troubleshooting section 

1.1 2022 Dec 12 Fixed general purpose output voltage high voltage conditions. 

1.0 2020 June 27 Removed “Preliminary” watermark. 
Removed “Why is this document preliminary?” section. 
Added calibration validation procedure. 
Added heading numbers 
Improved GPIO description. 
Added images using UI 0.8.16 and JS110 production hardware. 
Add “Meet Your Joulescope” section. 
Expanded “Theory of Operation” section. 
Grammar improvements. 

0.6 2019 Oct 16 Added GPO current and power specifications. 
Added GPI information. 
Clarified annotations, markers and cursors. 
Increased over-range settling time from 3 µs to 5 µs. 
Updated directions for UI 0.6. 

0.5 2019 Jun 20 Added table of contents to table of contents. 
Updated GPI/O section for production rev H.  Added statement about 
software support. 
Fixed typos and grammar. 
Updated compliance information. 
Updated for 0.4.x software. 
Updated “Why is the document preliminary”. 

0.4 2019 Mar 11 Updated electrical isolation section for rev E 

0.3 2019 Mar 1 Added electrical isolation section 
Added GPI/GPO 
Added Typical Behavior section with step response 
Fixed SI unit capitalization: See the definitive SI Brochure 

0.2 2019 Feb 12 First public release 

0.1 2018 Dec 17 Initial draft 

 

https://www.bipm.org/en/publications/si-brochure/section5-2.html

