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1. Introduction 
 

 

 

Multimeter view Oscilloscope view 

 

The Joulescope User Interface displays measured data from instruments including the Joulescope JS220 

and Joulescope JS110.  These instruments provide high-dynamic range current measurements and 

voltage measurements to enable a variety of applications including: 

• Microprocessor and microcontroller power profiling and optimization 

• Hardware power optimization 

• Microcontroller and device sleep current optimization 

• Hardware and software troubleshooting 

• Software characterization and interrupt service routine profiling 

• USB inrush and suspend current pre-compliance testing  

• General-purpose current, voltage, power, charge, and energy measurement 

The UI is the quickest and easiest way to configure tests, capture data, and analyze the results.   

The UI displays instantaneous voltage, current, power, and energy, like a multimeter.  The multimeter 

provides a quick and easy summary of the present state of your device. 

The UI also displays waveforms over time, like an oscilloscope.  This oscilloscope view allows you to 

identify and to troubleshoot dynamic behavior and short events, including inrush current, event 

handlers, and tasks.   
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2. Key benefits 
 

• Easy to use:  Simply install the UI on your host computer and connect your Joulescope.  View 

live statistics and waveforms immediately.  Easily access the data you need to make informed 

decisions. 

• View and analyze:  Explore, measure, and analyze captured data with a variety of included tools. 

• Record waveforms: Record for as long as you like.  The custom, open-source JLS file format 

makes exploring huge files quick and effortless. 

• Cross-platform: The UI works with Microsoft® Windows® 10 & 11, Apple® macOS® 12, 13, 14 & 

15, and Linux®.  For Linux, only Ubuntu 22.04 LTS is officially supported.  The UI only supports 

64-bit operating systems with 64-bit Python 3.10+.   

• Open-source:  The UI is open-source on GitHub without annual maintenance fees.  Buy your 

Joulescope today and use it on your terms.  

• Compatible:  Works with the Joulescope JS220 and original Joulescope JS110. 
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4. Installation 
The Joulescope software is available to download at  

www.joulescope.com/download/ 

Click on the download link for your operating system and platform architecture.  We recommend 

installing the Joulescope software on the native operating system, not under a virtual machine, due to 

Joulescope’s demanding USB communication requirements. 

See the appropriate section below for the installation for your operating system. 

4.1. Microsoft® Windows 10 & 11 
Click on the installer executable.  Read and accept the license agreement, and click Next.  Accept the 

default installation location or change it as need, then click Next.  Select Next and Install.  Finally, click 

Finish to complete the setup and launch the Joulescope UI. 

4.2. Apple® macOS 12, 13, 14 & 15 
On macOS, download the dmg file which supports both x86_64 (Intel) and arm64 (Apple Silicon) 

platforms.  Open the dmg file and then drag joulescope.app to the Applications folder.  Once the 

installation completes, you can eject the dmg file. 

The macOS distribution is currently signed and notarized, but it is not distributed through the Apple 

Store.  macOS should display that the application has been checked by Apple, but that it was 

downloaded from the web.  It should install and run if you accept this warning. 

If you receive a security warning, control-click the Joulescope application in Finder, then select open to 

bypass these security warnings.  You will need to repeat the control-click, open process several times 

(usually twice) until macOS finally allows the Joulescope software to launch.  After going through this 

process to grant permission once, subsequent runs will start normally. 

4.3. Ubuntu 22.04 LTS (Linux) 
Unpack the tar.gz file to the location of your choice.  Then run the joulescope_launcher binary in the 

extracted directory.  You may need to install additional dependencies.   

sudo apt install libudev-dev libxcb-cursor0 

Many Linux systems, including Ubuntu, use “udev” to manage devices and grant permissions.  You will 

need to install a udev rule that grants Joulescope hardware access to your account.  Download and 

follow the instructions in this file: 

https://raw.githubusercontent.com/jetperch/joulescope_driver/main/99-joulescope.rules 

If you receive the error Could not load the Qt platform plugin "xcb" in "" even 

though it was found, then you need to install additional Qt6 dependencies.  You can identify the 

missing dependencies by running export QT_DEBUG_PLUGINS=1 before starting the Joulescope 

UI.  Then install the missing dependencies with your package manager. 

http://www.joulescope.com/download/
https://raw.githubusercontent.com/jetperch/joulescope_driver/main/99-joulescope.rules
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4.4. Python (all platforms) 
Follow the instructions for your platform to install python 3.10 or greater.  Then install the Joulescope 

UI: 

    <python> -m pip install -U --upgrade-strategy=eager joulescope_ui 

Replace <python> with path to your installed python binary. 

Whenever you want to run the Joulescope UI, type: 

    <python> -m joulescope_ui 
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5. Meet the Joulescope UI 
When you start the Joulescope UI for the first time or after updates, it greets you with the Quick Start 

Guide.  Please read through this and click OK to continue.  You will see the Multimeter View. 

Before diving into the views, let’s take a quick look at the window structure: 

 

The Menu Bar allows quick access to commonly used features and settings: 

Item Description 

File Open recordings and exit application. 

View Select the active view and manage (add, delete, reorder) views. 

Widgets Add a widget to the active view. 

Tools Additional tools. 

Help Get help and more information. 

 

The Side Bar allows quick access to commonly used features and settings: 

Icon Definition Description 

 
Target power Toggle the power to target devices. 

 
Fuse engaged Clear engaged fuses. Turns red & blinks when any fuse engaged. 

 
Signal sample streaming Enable/disable sample streaming (pause waveform display) 
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Signal sample recording Enable/disable sample stream recording. 

 
Statistics display Enable/disable statistics streaming (pause multimeter display) 

 
Statistics recording  Enable/disable statistics stream recording. 

 
Device control Show device control settings for every connected instrument. 

 
Memory buffer settings Show memory buffering settings. 

 
Application settings Show all application settings. 

 
Get help Show a number of ways to get help with links. 

 
Additional settings and actions Additional settings and actions. 

 

The Status Bar shows current activity.  For example, it shows the recording duration for any active 

recordings. 

The Central Widget Area is where you can add, remove, and rearrange widgets.  You can also undock 

widgets into other Windows. 

When in doubt about a UI feature, hover the mouse over it, which often displays a Tooltip.  Note that 

this only works when the Joulescope UI is also the active window.  If you click on another application, 

you have to click on the Joulescope UI to make it active. 

Want to configure something?  Right-click (control-click on macOS) with the mouse to bring up a 

context-sensitive menu that varies based upon what you click.   

5.1. Multimeter View 
The Multimeter View provides the present operating state at a glance.   
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The multimeter view displays several quantities: 

• Electrical current in amperes (A) 

• Electrical voltage in volts (V) 

• Power in watts (W) 

• Charge in either coulombs I or amp-hours (Ah). 

• Energy in joules (J) or watt-hours (Wh). 

This display, along with all other value displays in the Joulescope software, the SI standard prefixes for 

orders of magnitude: 

Prefix Power Name 

G 109 giga- 

M 106 mega- 

k 103 kilo- 

m 10-3 milli- 

µ 10-6 micro- 

n 10-9 nano- 

p 10-12 pico- 

 

The multimeter view updates every half second (0.5 seconds) by default.  The software computes and 

displays the statistics over each half-second time window.  The large numbers are the mean (also called 

average) value of that quantity over the window.  The software also displays: 
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• std: The standard deviation 

• min: The minimum value 

• max: The maximum value 

• p2p: The peak-to-peak value, which is equal to (max – min) 

Note that charge and energy only display the time since the integration started since these other 

statistics are not meaningful.   

Every update represents only the data recorded over the last half-second. 

Press the Hold button to pause the display update.  The charge and energy accumulators will continue 

to run properly in the background.  You can press the Statistics Display  button, which holds all 

widgets that display these statistics. 

Press the Accumulate button to compute the statistics indefinitely until you press the button again.  

While Accumulate is active, the software extends the statistics to combine each new window without 

discarding results from previous windows.   

5.2. Oscilloscope View 
The software includes an Oscilloscope View that displays waveforms over time.   To enter this view, 

select View → Oscilloscope.  

 

The Oscilloscope view consists of the Waveform Widget.  The Waveform Widget has several regions 

moving top to bottom: 

• Waveform summary: shows the waveform to the full available time extents.  The blue region 

highlights the time domain visible below. 
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• x-axis: Displays the time in UTC.  The first line shows the relative UTC offset.  The next line 

shows the values relative to the offset. 

• Signal waveforms: The plot for each selected signal showing the signal value over time. 

• Control: Settings that affect the waveform display. 

When you first select the Oscilloscope View with a connected Joulescope, it will display the live 

streaming data from the instrument.  You can click the Play  button at the top left to pause the 

waveform buffer.  Press again to resume. 

You can easily navigate the collected data.  Move the mouse over the plot of interest, and use the scroll 

wheel to zoom.  Hold the left mouse button and drag the mouse cursor to pan.  Alternatively, hold the 

shift key while using the mouse scroll wheel.   

For the y-axis, the display automatically adjust to display the available data.  However, you can manually 

control the y-axis view range.  Hold the Ctrl key (command ⌘ on macOS) and use the mouse wheel to 

zoom.  Hold Ctrl, hold the left mouse button, and drag the mouse cursor to pan.  Alternatively, hold Shift 

+ Ctrl while using the mouse scroll wheel.  To return the automatic view range behavior, right-click on 

the plot area and select Y-axis auto range. 

Right-click on any region for more options.  You can add annotations, including: 

• x-axis single markers: Display the average value and range for all samples represented by a 

pixel. 

• x-axis dual markers: Display the statistics over a region of interest.  Right-click on the dual 

markers for additional analysis options. 

• y-axis single markers: Display the y-axis value 

• y-axis dual markers: Display the y-axis values and delta. 

• Text annotations: Add shapes and text to denote areas of interest. 

The software computes statistics quantities over the full-time window shown in the present view for 

each waveform.  The software displays the statistics on the right edge of the window.  The statistical 

quantities are: 

• avg: The mean (also called average) value 

• std: The standard deviation 

• rms: The root-mean-square value 

• min: The minimum value 

• max: The maximum value 

• p2p: The peak-to-peak value (max – min) 

• ∫: The integral over the time window  

The control area contains a variety of buttons that affect the display.  You can hover the mouse cursor 

over each to display a tooltip.  The tooltip contains additional information for each option. 

You can use x-axis dual markers to perform further analysis.  Right-click one of the dual markers and 

select Analysis for the available options: 
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5.3. Energy and Charge 
Joulescopes measure current and voltage at 2,000,000 samples per second.  It then multiplies current by 

voltage to compute power.  Joulescopes then integrate current to compute charge and integrate power 

over time to compute energy.  The Joulescope UI displays charge and energy in both the Multimeter 

View and Oscilloscope View.  This value starts accumulating when the software starts.  Use 

Tools → Clear Accumulators to reset them to zero at any time. 

The energy value and charge value provide a simple measurement to observe changes, especially for 

software.  You can baseline the performance of an operation by recording the measured energy or 

charge value.  You can then make changes, repeat the test, and observe the new energy or charge value.  

The Oscilloscope View enables you to investigate in further detail. 

5.4. Signal Management 
Instruments and recordings provide signals that can then be viewed or recorded.  The Joulescope UI 

contains several features to manage signals. 

Each device allows signal customization.  Click the Device Control icon on the Sidebar to manage the 

signals provided by each device: 
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The Waveform Widget separately allows you to select which Signals it displays: 

 

When you record a JLS file, the dialog allows you to select the signals to record: 
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Recording more signals requires more storage space.  To keep your storage space to a minimum, only 

select the signals you need. 

5.5. Triggers 
Joulescope UI 1.1 and newer include a Trigger widget.  The Trigger widget can detect start and stop 

conditions, and perform start and stop actions.  The Trigger can run in either Single or Continuous 

mode.  After configuring the desired operation, click the button at the top right to start the Trigger 

operation. 
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Joulescope UI 1.1 performs the trigger condition detection on the host.  This detection includes 

communication latency from the Joulescope to the host computer.  The Set output operation may have 

a significant delay (on the order of 100 milliseconds) between the actual condition and the output 

change.  We do plan to move the condition detection to the JS220’s FPGA for significantly reduced 

latency. 
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6. Multiple Instrument Support 
The Joulescope UI supports multiple simultaneously connected Joulescope instruments.  The UI includes 

the concept of a default device. 

 

The UI will automatically select the initial default device.  Change the default device using the Device 

Control widget. 

When multiple instruments are connected, the Waveform widget displays an additional channel control 

widget. 
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Click on the color bar to enable or disable the channel.  Right-click on the channel name to select a 

different device.  Click on the channel to select the active channel. 

The Waveform widget uses the active channel to compute the right-hand side statistics and marker 

statistics.  Changing the active channel will change the statistics computations.  The active channel also 

determines the y-axis labels for the current range signal. 
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7. Graphics configuration 
The Joulescope UI will use the default graphics configuration.  On macOS and Linux, this works 

seamlessly. 

Unfortunately, Windows has a known issue with integrated Intel graphics that can cause application 

crashes.  If your computer only has integrated Intel graphics, we recommend that you update your Intel 

graphics drive to the latest.  If you still see crashes, you can try using the software OpenGL renderer.  

The UI will prompt you to make the switch, which only takes effect after you close and reopen the 

application.  You can later configure the OpenGL renderer by selecting Widgets → Settings → Common 

→ opengl. 

Even Windows computers with discrete graphics cards sometimes select Intel graphics depending upon 

the power settings.  In this case, you can manually configure the Joulescope UI to use the high-

performance discrete graphics card.  Open Windows Settings.  Select System → Display → Graphics.  

Select the joulescope.exe executable. 

 

This will add the Joulescope UI to the list.  Select Joulescope UI and press Options.  Select High 

performance and press Save. 
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The next time you start the Joulescope UI, it will use the discrete graphics card. 
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8. Internationalization and Localization 
Joulescope UI 1.1 introduced translations to several languages including: 

Code Language Language 

ar Arabic  العربية 

de German  Deutsch 

el Greek ελληνικά 

en English (US) English 

es Spanish español 

fr French français 

it Italian italiano 

ja Japanese 日本語 

ko Korean 한국어 

zh Chinese (simplified) 中文 

 

By default, the UI will use the OS language configuration. 

You can change the language by selecting Help → Language.  Help is the last menu bar item and 

Language is the second item from the top.  The UI will close when you click OK.  The language change 

will take effect when you launch the UI again.  This feature was added in 1.1.11.  

Alternatively, you can also set the LANG_JOULESCOPE_UI environment variable, which will override the 

OS language.  Use the 2-letter language codes above.  At this time, the UI only offers basic language 

translations without country codes. 

As of Joulescope UI 1.1.11, the UI does not offer further locale customizations, such as number formats. 

All language translations were generated primarily by DeepL with some contributions from the 

Joulescope community.  Please open a GitHub issue to submit corrections. Please include the language.  

For each correction, please list the existing language string and the recommended corrected string. If 

you are comfortable with GitHub pull requests, simply open a pull request with the fixes to the 

appropriate file: 

joulescope_ui/locale/locale/LC_MESSAGES/joulescope_ui.po 

Alternatively, contact us with the same information. 

 

https://github.com/jetperch/pyjoulescope_ui/issues
https://www.joulescope.com/pages/contact


Revision 1.7 Joulescope UI User’s Guide Page 22 / 29 
 www.joulescope.com 

9. Source Code 
The UI is open source and written in Python 3.10+.  The UI consists of several layers: 

Repo name Python package name Description 

pyjoulescope_ui joulescope_ui The Joulescope User Interface written in Qt6/PySide6 

pyjoulescope joulescope The Joulescope Python “driver” with 
pyjoulescope_driver adapter for JS110 applications.  The 
UI only uses this package to provide JLS v1 read support. 

joulescope_driver pyjoulescope_driver Native JS220 and JS110 driver with Python bindings 

jls pyjls High performance file storage for Joulescope data 

 

The Joulescope package was designed so that you can script custom Joulescope actions and integrate 

Joulescope into your applications.   

See the GitHub repositories for the latest details. 

• https://github.com/jetperch/pyjoulescope_ui 

• https://github.com/jetperch/pyjoulescope 

• https://github.com/jetperch/joulescope_driver 

• https://github.com/jetperch/jls 

You can find examples of how to use Joulescope in your Python application at: 

https://github.com/jetperch/pyjoulescope_examples 

See the documentation: 

https://joulescope.readthedocs.io/ 

The Joulescope software depends upon other software and libraries.  See CREDITS.html for 

pyjoulescope_ui and pyjoulescope. 

https://github.com/jetperch/pyjoulescope_ui
https://github.com/jetperch/pyjoulescope
https://github.com/jetperch/joulescope_driver
https://github.com/jetperch/jls
https://github.com/jetperch/pyjoulescope_examples
https://joulescope.readthedocs.io/
http://htmlpreview.github.io/?https://github.com/jetperch/pyjoulescope_ui/blob/master/CREDITS.html
http://htmlpreview.github.io/?https://github.com/jetperch/pyjoulescope/blob/master/CREDITS.html
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10. Plugin Support 
The Joulescope UI supports plugins beginning with version 1.1.  A plugin adds features and 

functionalities to the Joulescope UI without modifying the UI source code.  You can install plugins even 

when using the Joulescope UI distributions. 

    Plugins run with the same permissions as the Joulescope UI. Active plugins have full access to run 

arbitrary code on this computer. Make sure you trust a plugin before activating it. 

The UI currently does not yet have a mechanism to discover available plugins. 

See the doc/plugin.md for additional documentation, including plugin development. 

https://github.com/jetperch/pyjoulescope_ui/blob/main/docs/plugin.md
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11. Troubleshooting 
 

11.1. Reporting issues 
While we work diligently to ensure that the Joulescope UI is stable, sometimes the unexpected happens.  

If the Joulescope UI fails to launch or crashes, it may prompt you to report the issue.  Please report 

issues and include your email in the report so that we can work with you to solve the issue. 

If the Joulescope UI crashes but does not prompt you to report the issue, please manually report the 

issue when you next start the Joulescope UI.  Select Help → Report Issue.  Please include your email so 

that we can work with you to solve the issue. 

11.2. Windows memory compression 
Microsoft Windows includes memory compression by default.  While this is normally not an issue, it can 

slow down performance on Windows, especially if you increase the Joulescope memory buffer size on 

computers with large RAM.   

To check if memory compression is enabled, launch PowerShell as Administrator and type: 

Get-MMAgent 

If MemoryCompression is True, then memory compression is enabled on your computer. 

To disable memory compression, launch PowerShell as Administrator and type: 

Disable-MMAgent -mc 

11.3. Virtual Machines 
We do not support running the Joulescope UI in virtual machines.  The Joulescope UI requires low-

latency USB communication which can be problematic under virtual machines.  If you find that running 

the Joulescope UI within your virtual machine works, great!  If not, please install the Joulescope UI on 

the native operating system. 

11.4. Recording to Network Storage 
Joulescopes at full sample rate generate a lot of data.  When recording, we strongly recommend 

recording to a local solid-state drive (SSD) or hard disk drive (HDD).  If your computer lacks sufficient 

storage, you can purchase an external HDD, which is very affordable.   

Networks and network storage are often not able to keep up with the Joulescope data rates.  If you 

need to put your recording to network storage, we recommend copying it over after the recording 

completes. 

11.5. UI opens to white / blank window 
ASUS Sonic Studio 3 and ASUS Sonic Radar 3 cause a known issue with all OpenGL applications in dual-

monitor setups.  If you close the Joulescope UI with a Waveform widget on the second monitor and then 

restart the UI, it will appear as a blank, white window.  The workaround is to either keep the UI on the 

primary monitor or uninstall both ASUS Sonic Studio 3 and ASUS Sonic Radar 3.  For more details, see 

issue #252 on GitHub. 

https://github.com/jetperch/pyjoulescope_ui/issues/252
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12. Contact 
To purchase a Joulescope product, visit: 

https://www.joulescope.com 

If you have questions regarding operation of Joulescope, search the website at: 

https://www.joulescope.com/  

And visit the forum: 

https://forum.joulescope.com/ 

If you wish to contact Jetperch regarding the operation of your Joulescope, contact us through email at: 

support@joulescope.com  

 

 

Location 

Jetperch LLC 

3470 Olney – Laytonsville Rd. 

Suite 104 

Olney, MD 20832-1734 

USA 

 

https://www.joulescope.com/
https://www.joulescope.com/
https://forum.joulescope.com/
mailto:support@joulescope.com
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13. Glossary 
 

Accuracy 

The average variation in the bias between measurements and truth.  Good measurements are both 

accurate and precise. 

Ammeter 

A device that measures electrical current. 

Burden Voltage 

The voltage drop that occurs through the test equipment device.  For shunt ammeters, the burden 

voltage includes the voltage across the shunt resistor, connectors, fuses, and any additional resistance in 

the device. 

Current 

The flow of electric charge per time from positive voltage to negative voltage, measured in amperes (A), 

often called amps.  One amp is one coloumb of charge flowing per second.  One coloumb is 

approximately 6.242 x 1018 electrons, but electric current is defined opposite to the electron flow. 

Energy 

The total power exerted over time, measured in joules (J).  Energy is the time integral of power. 

Insertion Loss 

The loss in signal power due to a device in the signal path, most commonly used in reference to radio 

frequency (RF) or telecommunications.  See Burden Voltage. 

Multimeter 

A multifunction device that usually incorporates a voltmeter and shunt ammeter, at a minimum.  A 

standard multimeter supports only one measurement quantity at a time. 

Ohm’s Law 

The equation that relates voltage, current and resistance: V = I * R 

Oscilloscope 

A device that graphically displays a one or more signals, usually voltages, varying over time as a two-

dimensional plot with time on the x-axis and the signal on the y-axis. 

Power 

The time-rate of doing work, measured in watts (W).  Power is voltage multiplied by current. 

Precision 

The amount of variation between measurements of the same value relative to each other.  Good 

measurements are both accurate and precise. 

Resistance 

The quantity of opposition to the flow of electric current. 
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Shunt Ammeter 

An ammeter that measures the voltage across a resistor, and then uses Ohm’s Law to compute current. 

Shunt Resistor 

The resistor used by “Shunt Ammeters” to detect current using Ohm’s Law:  I = V / R.  Given a known R 

and a measured V, the ammeter computes I. 

Universal Serial Bus (USB) 

The now ubiquitous standard for connecting computers and peripherals.  Joulescope connects to the 

host computer using USB 2.0 high-speed operating at 480 Mbps. 

Voltage 

The electric potential difference, measured in volts (V). 

Voltmeter 

A device that measures electrical voltage. 
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14. User’s guide information 
This section contains information regarding this document.  See the other sections of this document for 

information regarding the Joulescope product. 

14.1. Copyright notice 
© 2019-2024 Jetperch LLC 

All material in this Joulescope JS220 User’s Guide, including the text, images, design, and logos, are 

owned by Jetperch LLC, either through copyright or trademark, unless otherwise indicated.  No part of 

this User’s Guide may be reproduced in any form or by any means without prior written consent from 

Jetperch LLC as governed by the United States and international copyright laws.   

14.2. Publisher 
Jetperch LLC 
3470 Olney – Laytonsville Rd 
Suite 104 
Olney, MD  20832-1734 
USA 

14.3. Warranty 
The Joulescope UI User’s Guide is provided AS-IS with no other representations or warranties, expressed 

or implied, of any kind including, but not limited to, any implied warranty of merchantability of fitness 

for a particular purpose.  Jetperch LLC does make reasonable efforts to present accurate and reliable 

information in this Joulescope UI User’s Guide. 

The information in this User’s Guide is subject to change.  The most up-to-date version of this User’s 

Guide can be retrieved from http://www.joulescope.com/.    

http://www.joulescope.com/
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14.4. Change log 
Revision Date Description 

1.7 2024 Oct 1 Updated i8n to describe new Help → Language  
Indicated macOS 15 support in addition to 12-14 

1.6 2024 Apr 25 Updated for Joulescope UI 1.1: Triggers, translations & plugins 

1.5 2024 Feb 12 Added troubleshooting blank / white screen. 
Bumped required python from 3.9 to 3.10. 
Update macOS text to include 14 support. 
Updated copyright dates. 

1.4 2023 Dec 11 Updated multiple, simultaneous device support section 
Added Graphics configuration section. 

1.3 2023 Oct 9 Added troubleshooting section 

1.2 2023 Jun 16 Updated Linux installation instructions. 

1.1 2023 Jun 15 Updated macOS support (added 12, universal2) 

1.0 2023 Jun 1 Initial version 
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